Fix:コマンド "dotnet-lambda" に一致する実行可能ファイルが見つかりません


以下のコマンドを実行して、Lambda関数のデプロイ用ファイルを作成しようとしたところ、表題のエラーが発生してしましました。

> dotnet lambda package --configuration Release --framework netcoreapp2.1
コマンド "dotnet-lambda" に一致する実行可能ファイルが見つかりません

これは、Amazon.Lambda.Toolsがインストールされていないことが原因です。

github.com

下記コマンドで、Amazon.Lambda.Toolsをインストールすることでエラーは発生しなくなりました。

> dotnet tool install -g Amazon.Lambda.Tools